Search Form and Social Buttons

HotThemes Logo and Top Menu

To request a forum account, please login here and open support ticket. Only customers with active order(s) can open forum account!

× Discussion about "Architecture" Joomla template.

Topic-icon Top menu and joomla buttons are moving around

  • susanag
  • susanag's Avatar Topic Author
  • Visitor
  • Visitor
6 years 1 month ago #5432 by susanag
Hello, its me again!

When I open my site, the buttons of my Poll appear over the bigger image in the panel of Hot Designation or the "Search" button moves out of its place. What should I do to prevent overlay occurs?

It looks like this:



And it should looks like this instead:



My URL is:

www.aquituevento.com/

Besides, lately I see my tabs in the top menu are moving too when my site start to charging and if I put my cursor over they, look like this:



What shoul I do to prevent all of this strange efects?

I'll appreciate your kindness.

Thanks

Please Log in to join the conversation.

More
6 years 1 month ago - 6 years 1 month ago #5465 by ivan.milic
Hi,

Your problem occurres in IE 8 until page is not loaded completely. This script may solve your problem try it (not sure it will work). Puthi it just after body tag. Script block:


<div id="wait_screen" style="display:none;">
Please wait for page to load...
</div>

<script type="text/javascript">


if(jQuery.browser.msie && jQuery.browser.version == 8){

var mDialog = jQuery("#wait_screen");

mDialog.dialog({

bgiframe: true,

autoOpen: false,

height: 100,

modal: true,

closeOnEscape: false,

resizable: false,

draggable: false,

open: function(event, ui) {

jQuery(this).parent().children().children('.ui-dialog-titlebar-close').hide();

}

});
mDialog.dialog('open');
window.onload = function(){
mDialog.dialog('close');
}
}

</script>

note that jQuery core and UI must be loaded before.
Last Edit: 6 years 1 month ago by ivan.milic.

Please Log in to join the conversation.

More
6 years 1 month ago #5486 by ivan.milic
Hi ,

I have made it work. Now when you enter page in IE 8 message will appear:
"Please wait for page to load"

That message is in div just above script. You can change that text or put some other content line image in it.

Please Log in to join the conversation.

  • susanag
  • susanag's Avatar Topic Author
  • Visitor
  • Visitor
6 years 1 month ago #5621 by susanag
Hello again!:blush:

I really appreciate your kindness and how much are you helping in my site construction. Especially now in this touble that involves different browsers.

Now I find IE6 is not showing the tabs at all. Do you have some idea about what to do? Top menu looks just a long continous line without buttons in IE6. I would like be sure every user could see the main navigation.

Sorry if I'm asking so much. I know you have been helping me a lot. I just need this fix to present the proyect to my bosses.

Thank you.

Please Log in to join the conversation.

More
6 years 1 month ago #5624 by ivan.milic
I have no IE6 and I cant install it or reproduce it's working.
But if you think the wait screen causes problems you can change ths line of script:

if(jQuery.browser.msie && jQuery.browser.version == 8){

to

if(jQuery.browser.msie && jQuery.browser.version < 9 && jQuery.browser.version > 6){

Please Log in to join the conversation.

  • susanag
  • susanag's Avatar Topic Author
  • Visitor
  • Visitor
6 years 1 month ago #5630 by susanag
Hello,

I've changed that code line, but problem in IE6 persist.

It looks like this:



Top menu is just a long blue line. Besides, Styles in Hot Designation looks strange as you can see in the red circle.

Could you help me? Thanks again.:blush:

Please Log in to join the conversation.

Time to create page: 0.127 seconds

Links, Partners and Social Media