Menu behavior on a bilingual site

More
2 years 11 months ago - 2 years 11 months ago #46600 by Danimeeka
Hi,

The site I am working on is at www.lmslawyers.com.au/joomla . I am attempting to create it in two languages - Chinese and English - and have also created all articles and menus in language "All". I have followed the steps in these two articles:

www.templatemonster.com/help/joomla-3-x-...guage-site.html#gref
www.slideshare.net/erictiggeler/creating...-guide-eric-tiggeler

So far so good. A remaining issue is with the main (top) menu. I have not created the website using different templates for the different languages, by the way, so I hope this is OK.

Issue 1: The sub menus are not showing. I have set them up in template menu settings exactly the way the demo topmenu was set up. I have read topic #46384 - should I copy the code provided there and use it for Hot Flat?

Issue 2: Except when on the Home page, clicking any menu item returns you to the "All" menu. How do I make it so that when in Chinese, clicking the Chinese "Contact" page for example takes you to a screen where the Chinese menu still shows? Topic #46395 seems relevant but I do not see how to have three modules all simultaneously in the topmenu position in Layout Builder. I have attached an image of my Layout Builder showing the topmenu row.

By the way, I am using two Hot Flat templates, one for the Home page (has a big logo) and one for all other pages (with a smaller version of the logo).

Many thanks,
Julia.
Attachments:
Last edit: 2 years 11 months ago by Danimeeka. Reason: Attachment didn't appear to attach. Trying again.

Please Log in or Create an account to join the conversation.

More
2 years 11 months ago #46602 by milos
Hello,

Please re-download from our site and re-install it (or just upload new template files by FTP to keep your data). We have fixed this issue 2-3 weeks ago. I think it will fix both issues.

Thanks,
Milos

Please Log in or Create an account to join the conversation.

More
2 years 11 months ago #46610 by Danimeeka
Hi Milos,

Thanks, I will try that.

I have made several changes to template_css.css. Do I need to replace this file also? If so, and for future reference, should I be putting all my changes in a custom.css file in the same folder instead of directly changing template_css.css? In other words, how do I make changes as overrides rather than directly changing the template files?

Thanks,
Julia.

Please Log in or Create an account to join the conversation.

More
2 years 11 months ago #46612 by milos
Hello,

If you modified template_css.css file, then don't replace it with new file. This file has not been updated and it's not important for this issue anyway.

Regards,
Milos

Please Log in or Create an account to join the conversation.

More
2 years 11 months ago #46615 by Danimeeka
Hi Milos,

Thanks - I have left my template_css.css in place as well as template_css.php, and used the rest of the updated template files.

Updating the template files fixed one issue: the submenu items now show as dropdowns.

Still remaining is the issue that when any menu or submenu item other than Home is clicked, the user is taken to a page where the main content is of the correct language, but the top menu reverts to the default top menu (language = 'All').

What can I do to ensure the language-appropriate menu is what appears? Is this something I have done?

Thanks,
Julia.

Please Log in or Create an account to join the conversation.

More
2 years 11 months ago #46616 by Danimeeka
Just one other point to mention - when the website does its unfortunate change to the 'all' language top menu, the language switcher disappears.

I have unpublished the module used by this 'all' language top menu, so really can't comprehend why appears at all.

Please Log in or Create an account to join the conversation.

Moderators: milos
Time to create page: 0.108 seconds