× Discussion about "eCommerce" VirtueMart/Joomla template

Topic-icon Fatal Errors in Virtuemart 2.0 with Joomla 2.5

More
6 years 3 months ago - 6 years 3 months ago #14760 by Abbring
Hello,

I get the following error when trying to manage my media files inside virtuemart > shop > media files:

Fatal error: Call to a member function getResultsCounter() on a non-object in myurl.com/administrator/components/com_virtuemart/views/media/tmpl/default.php on line 38

I am using the 2.5 ecommerce template on Joomla 2.5.1,

Also, when I am trying to edit the product categories I receive this error: Warning: Invalid argument supplied for foreach() in myurl.com/administrator/components/com_virtuemart/views/category/tmpl/default.php on line 75

Fatal error: Call to a member function getListFooter() on a non-object in myurl.com/administrator/components/com_virtuemart/views/category/tmpl/default.php on line 140


If I try to change any manufacturers details, same kind of problem and this error: Fatal error: Call to a member function getListFooter() on a non-object in myurl.com/administrator/components/com_virtuemart/views/manufacturercategories/tmpl/default.php on line 84




What is causing all of this not to work? Can it be fixed?

Thank you

Derek
Last edit: 6 years 3 months ago by Abbring.

Please Log in or Create an account to join the conversation.

More
6 years 3 months ago #14762 by Abbring
Also, this was just a fresh install on a new domain.

Please Log in or Create an account to join the conversation.

More
6 years 3 months ago #14768 by Abbring
And I did a wipe/fresh install of everything and still have the same errors.

Please Log in or Create an account to join the conversation.

More
6 years 3 months ago #14771 by milos
VirtueMart 2.0.0. is not 100% compatible with Joomla 2.5. We must wait for VirtueMart 2.0.1. You can use VirtueMart on Joomla 1.7 until then and upgrade later.

Please Log in or Create an account to join the conversation.

More
6 years 3 months ago #14800 by Abbring
I had read that in several places, then got an email from hotjoomlatemplates saying all templates were good to go for 2.5 :) No worries, thank you for your support, I will install 1.7

Please Log in or Create an account to join the conversation.

More
6 years 3 months ago #14822 by Abbring
Would this have anything to do with my server being on PHP 5.2 and not PHP5.3+?

Please Log in or Create an account to join the conversation.

Time to create page: 0.138 seconds