Error when trying to update Joomla 4 template hotstart install

  • paul1
    Active member
  • Topic Author
  • Member
  • Member
More
2 years 7 months ago #48074 by paul1
Hi

Just uploaded J4 Host hot_host4x_hotstart.zip to a new account.

Quick look and everything fine.

But .. get a message to upgrade to J4.0.3   and I get this message (below).  Any ideas????An error has occurred.

1064 You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near '' at line 1

Please Log in to join the conversation.

  • milos
    Support Staff
  • Moderator
  • Moderator
More
2 years 7 months ago #48076 by milos
Hello,

If your current version is 4.0.1, you should first update the "Update" Joomla component because it has a bug. Then you update Joomla. More details here: www.joomla.org/announcements/release-new...a-4-0-2-bug-fix.html

Thanks,
Milos

Please Log in to join the conversation.

  • paul1
    Active member
  • Topic Author
  • Member
  • Member
More
2 years 7 months ago #48078 by paul1
1. The current version was as provided in quick start by yourselves.
2. It shows as 4.0.2
3. The error is that it can't/won't update to 4.0.3

With your quickstart are any changes made to default J install?

Is there a quickstart without the Joomla install that I can load over my own install - that was I know what is happening.

Joomla support suggest issue with your quickstart :-)

Please Log in to join the conversation.

  • milos
    Support Staff
  • Moderator
  • Moderator
More
2 years 7 months ago #48080 by milos
Hello,

I just upgraded our Host template demo to Joomla 4.0.3 without any issues. So, the problem is related to your server. What MySQL server do you have (go to System > System Information to check this)? Our MySQL server version is 5.7.30.

Regards,
Milos

Please Log in to join the conversation.

  • paul1
    Active member
  • Topic Author
  • Member
  • Member
More
2 years 7 months ago #48084 by paul1
Thanks for assistance - appreciated.

Database version is 10.3.31-MariaDB-cll-lve

I have two J4 installs on same server - just installs I have done - nothing added. Both work fine :-(
Paul

Please Log in to join the conversation.

  • milos
    Support Staff
  • Moderator
  • Moderator
More
2 years 7 months ago #48085 by milos
Yes, MySQL server and MariaDB server are usually the same things, until you run into problems as I did a few months ago (not related to Joomla though). :)

Regarding the other websites (clean Joomlas), did you just install Joomla 4.0.3 on this server directly, or did you updated from Joomla 4.0.x to Joomla 4.0.3?

Try this:

1. Go to System > Maintenance > Database. Select Joomla CMS and click Update Structure. Then try to update again.

2. Download the patch package "Joomla! 4.0.2 to 4.0.3 Patch Package (.zip)" from downloads.joomla.org/cms/joomla4/4-0-3 and try to install this instead.

Regards,
Milos

Please Log in to join the conversation.

Time to create page: 0.344 seconds
Powered by Kunena Forum