Search Form and Social Buttons

HotThemes Logo and Top Menu

To request a forum account, please login here and open support ticket. Only customers with active order(s) can open forum account!

× Discussion about Hot Effects Slider Joomla module.

Topic-icon Effects Rotator not visible in Opera 10

More
6 years 10 months ago #1175 by erjati
It works fine in all modern browsers but Opera - a new install yesterday of the latest version (didnt work in Opera 9 either). I checked to see that javascript and all that is enabled in the browser - it was a default installation. I also tried the rotator with conflict mode on and off, and with jquery on and off. With it off there is no rotation of course. I checked the source for the template and only your module loads jquery.

When the page is loading you can see one of the images momentarily but then it is covered over by the page content below, which is not pushed down as it should be. Everything below it in the page moves up as if the module were not enabled, even when it is.

I love this module, and bought an unlimited license. Please see if you can fix this, maybe by adding a couple of different script options besides jquery, or by altering jquery.


You can take a look here.

Please Log in to join the conversation.

More
6 years 10 months ago #1177 by milos
Sorry about it. We are looking for solution. Will be posted here soon.

Please Log in to join the conversation.

More
6 years 10 months ago #1179 by milos
Please open file style.css (/modules/mod_hot_effects_rotator/tmpl) and edit #slider part. Make it:
#slider {
	position:relative;
	padding:0;
	margin:0;
	width:300px;
	height:150px;
}
In this example, width/height is 300/150, but you should enter values that you have entered in module properties.

Please Log in to join the conversation.

More
6 years 10 months ago #1185 by erjati
I changed the css you suggested and now the module does show in Opera (size is 200 high by 974 wide, by the way) BUT the effects are all strange. Sometimes looks like its trying to do several at once when it is set to random. The slices are visible in all effects, even the fade, so the image looks pieced together. Also, the far right end of the image has about a dozen slices that appear to be about 5px wide while the rest to the left are normal width. Also, while in the back end it is set to 974 wide and the same in the css the actual image effects extend too far to the right - narrow slices. It's up now, so take a look. Thanks so much for your work on this.

Also, I see I mistakenly used my email as a user name here. Can you edit that so it is just erjati? I don't want to get spambots picking up the email address. If that can't be done I would like the posts to be deleted when this is all fixed. Thanks.

Please Log in to join the conversation.

More
6 years 10 months ago #1186 by milos
You username has been changed.

I just checked your site with Opera 10.10 and all effects are shown fine.

Please Log in to join the conversation.

More
6 years 10 months ago #1198 by erjati
I is indeed working better, maybe i just needed to reload the one i was seeing the errors in.

There is still one minor issue: the images i used are 1000 px wide and i have the module and css set to 974 wide. In the other browsers only the 974 size shows but in Opera it shows the whole 1000 wide image, overlapping the right edge of the module space in the page design during most of each effect, cropping it off to 974 at the last moment before the next effect loads, which loads at 1000 px wide.

I can work around that for now by cropping the images to 974px wide for now, but it would be great if i didn't have to ever, because for example with this template I have tried the module in different locations and have needed anywhere from 904 to 1000 px wide and was glad it was cropping itself. And I have also altered the template in minor ways that have affected the necessary width of the module at times and I was glad I didn't have to re-do the images. It saved a lot of time. Fortunately, the images I use can be clipped this way without losing any critical parts of the image.

I really appreciate the work you are doing. Let me know if you can fix this remaining problem.

Please Log in to join the conversation.

Time to create page: 0.129 seconds

Links, Partners and Social Media