View the new Sparky Page Builder introductory video. Watch now

There are some requirements that your web server and browser should meet to run the Sparky Page Builder without problems.

Server Requirements

If you are running Joomla 3.x or 4.x on your server without problems, you are most likely ready to install the Sparky Page Builder.

Browser Requirements

Sparky Page Builder is fully compatible with the latest versions of all major browsers.

  • Google Chrome
  • Mozilla Firefox
  • Microsoft Edge
  • Apple Safari
  • Opera