Requirements - Installation - Sparky Docs - HotThemes

Search Form and Social Buttons

HotThemes Logo and Top Menu

There are some requirements that your server and browser should meet to run the Sparky Framework without problems.

Server Requirements

If you are running Joomla 3.x on your server without problems, you are most likely ready to install the Sparky Framework. However, even if your Joomla 3.x is working fine under PHP 5.3, for Sparky Framework it’s required to run PHP 5.4 or later on the server. PHP 7 is supported as well.

Browser Requirements

Backend (Joomla Administrator)

We recommend working with Webkit based browsers, such as Google Chrome, Safari or Opera. The Sparky Framework backend also works fine on Mozilla Firefox. If you are using Microsoft Internet Explorer, you will need IE11. Microsoft Edge browser is also supported.

Front-end (Actual Website)

All major browsers are supported:

  • Google Chrome 41+
  • Firefox 36+
  • Safari 8+
  • Opera 28+
  • Internet Explorer 9+
  • Microsoft Edge

Links, Partners and Social Media